Common Problems

original source1)

The loss of the web GUI on RED station is a known problem in FW 9.1 and earlier. There's a memory overflow after some time of operation. This overflow happens suddenly due to unknown circumstances. As there's no memory left, no more web access is possible as this needs a lot of memory. Unfortunately even a direct reboot link doesn't work. This will be possible in the next firmware. The station may even reboot in such a situation, because sometimes there's also no remote control communication possible.

  • It is advised to enable the automatic reboot at some random time.

This means, the CPU is not working. If this happened after uploading the firmware, then the flash procedure was not successful. Please double check the settings in the flash tool. Is the jumper close to the CPU put on the pins? If not, then the CPU has no power.

You are probably using the mini USB jack at the STM32F4DISCOVERY board for the power supply. Please use the mini USB jack of the controller board for power supply. It is not possible to use the mini USB jack of the STM32F4DISCOVERY board to power the controller with 5 Volt. This is a frequently made error.

First check, whether the board is powered via the mini USB jack of the controller, and not via the mini USB jack of the STM32F4DISCOVERY board. Then check, if you accidentally set the LCD contrast to 0 in the settings. Other possible reasons for a not-working display:

  • Check the supply voltage. If it’s over 5.2V, then the LCD might not work. You should stay below 5.1V. This is a hardware bug in PCB 10.3 and is fixed in later versions.
  • Measure the contrast voltage with a volt meter. It has to be around -4V.
  • Carefully check every pin/solder-joint at the display and the controller.

Check, if you accidentally switched the backlight off in the settings. The backlight does not work, when the controller has no firmware.

There could be a lot of different reasons for interferences.

  • Search a different place for your antennas.
  • Lower your gain. The default values are already very high. Check whether you still receive enough stroke signals by checking the statistics on our web-sites.
  • System RED: The LCD backlight can send out noise due to PWM dimming. Set it to 100.
  • Under specific conditions, a simple filter could be activated.

This means, the controller couldn’t communicate with the ENC28J60 network chip. Please check if everything soldered correctly and whether the chip is correctly placed in its socket. The crystal must have 25 MHz fundamental oscillation. If it’s a overtone type, the ethernet controller might not work!

If this had happened only once, then you shouldn’t care. On very rare occasions, the on-board programmer can do strange things and interfere with the CPU. Remove the USB cable for programming and also the power supply. After 10 seconds, power up the board again but don’t connect the USB on the STM32F4DISCOVERY. You can also remove the two jumpers labeled with ST-Link to disconnect the programmer.

If that didn’t help and you’ve got those faults from time to time, you should contact the developers. If possible, write down the hard fault codes.

In most cases, this is due to wrong soldering. Carefully check all solder joints. Please be careful when re-soldering the joints after the PCB has been fully assembled. It’s much more difficult to get access to the GPS solder joints due to some big parts around the GPS module.

If the GPS antenna status shows always intern (LCD: Int) or a shortcut (ERR) then you should double check the solder joints from the GPS module to the antenna connector. If you don’t find the problem, the you should send us at least two good photos (or post them in the forum) where the solder joints on both sides of the module can be clearly seen (see Fig. 58).

In some very rare occasions, interference can disturb the GPS module. Try a different place and always make some tests outside. Please check GNSS (GPS) too!

Figure 58: Close photograph of solder joints on one side.

This is a bug in the PA6H module which can be observed on very rare occasions. It happens only when the reception quality is good and a lot of satellites are tracked (> 14). This situation can take minutes and the controller shows GPS warnings. If you experience it, check it again on following days at the same time but some minutes earlier on each day. Contact us, if you can observe the behavior on two different days. There’s currently no real solution for that. Even a firmware update of the GPS module doesn’t help. You can position your antenna so that it does not receive so much satellites. Changing baud rate or SBAS and resetting the GPS can eliminate the symptoms for some minutes but won’t solve the problem.

original source2)

Although nothing else changed, the location of the antenna is ok, the cables and connectors are ok, suddenly the GPS accuracy and availability drops. There are reports that this may be caused by anomalies in the earth's magnetic filed with strong geomagnetic storms. Example August 28 in 2018. Quote: “A lot of the high activity can play heck with GPS signals… the recent effects were said to be most pronounced ±55°N… you're at about 53° I believe… My three systems, usually running at about 95-100 were in and out at ±75%, Reds and Blue,… and I'm at ±38°N… now they're back at 99+”.